score:0

For the error:

scala module 2.13.2 requires jackson databind version >= 2.12.0 and < 2.13.0 in scala

  • Try to remove old dependencies of Jackson and upgrade the plugin or added 2.12.0 series
  • All of Jackson packages that Azure SDKs use , you may need to pin each of them to a specific version and their version number set to the same one as of Spark.

OR

  • Try to add a different com.fasterxml.jackson.core dependencies version as per error and then you may need to override them explicitly.

    "com.fasterxml.jackson.module" %% "jackson-module-scala" % "2.12.5"
    

See 1. scala - Jackson conflicts in Apache Spark when used with Azure Java SDK - Stack Overflow

  1. Maven Repository: azure-core-serializer-json-jackson

Other References:

  1. Jackson compatibility issues GitHub
  2. scala -incompatible Jackson versions -SO , Scala module 2.12.3 requires Jackson Databind version 3 -SO
  3. Manage Scala & Java libraries for Apache Spark - Azure Synapse Analytics | Microsoft Docs

Related Query

More Query from same tag