score:0

Accepted answer

I use Intellij IDE and in File -> project structure, there is a section called Global library where scala sdk 2.10 was affected. switch to 2.11 correct the issue

score:-1

Sure, you should use the Akka version corresponding to your Scala version, 2.12:

<dependency>
    <groupId>com.typesafe.akka</groupId>
    <artifactId>akka-actor_2.12</artifactId>
    <version>2.5.0</version>
</dependency>

Scala 2.11 and Scala 2.12 versions are not binary compatible.


Related Query

More Query from same tag