score:0

Accepted answer

Your import

import com.github.siasia.WebPlugin._

failed to find path github and below. In your plugins.sbt you wrote:

// was libraryDependencies <+= sbtVersion(v => "com.github.siasia" %% "xsbt-eb-plugin"  (v+"-0.2.11.1")) 
addSbtPlugin("com.earldouglas" % "xsbt-web-plugin" % "0.7.0")

The github-path probably existed in the outcommented com.github.siasia.xsbt-eb-plugin. However the com.earldouglas.xsbt-web-plugin have only the path com.earldouglas.xwp. You should check out if any of the classes there (https://github.com/earldouglas/xsbt-web-plugin/tree/master/src/main/scala) resembles what you need to import.

score:0

Probably not related exactly to this package but similar. The library was present in sbt and everything looked ok. But I still was unable to build the project so I went to my $HOME/.ivy2/cache located the dependency directory and deleted it, then went back the $PROJECT_HOME/ and executed sbt build


Related Query

More Query from same tag