score:0

I just solved this issue in node v11.15.0 my solution was: with my "react-scripts" version in "3.0.1" I just update it to "2.1.8" and run npm install after. You can use this version or search for one that works for you. Another option is updating nodejs to the latest version, then remove modules and run npm install.

score:0

Currently, we did not found any permanent resolve, but you just create that app again or use yarn package manager to install all modules again in your react app then run yarn start. that's how I solve my issue in react app.

score:0

I was able to get it working after running: $sudo npm install npm@latest -g

score:0

I had this issue using the ng serve command. I tried all of the above combinations and none of them seemed to fix this issue permanently. A simple quick fix / get around for me was to close and reopen the terminal.

score:0

I had this error TypeError: fsevents is not a constructor and tried all answers (remove node_modules, uninstalling/installing fsevents, sudo npm cache clean --force, sudo npm install/uninstall) listed; but nothing resolved it. For some reason, fsevents is breaking for node version >v10.x.

Regenerating lockfile resolved this issue

npm i --package-lock-only

score:0

Run this command

npm install latest-version

score:0

Run: npm audit fix --force

Then, try again.

score:0

This often happens due to the continuous update to react and npm-packages.

Try to remove your node_modules

npm uninstall

delete your yarn.lock this will save tons of time and if you are using npm instead if yarn always updated.

run yarn install

score:1

I FINALLY resolved the issue. The fsevent error occurred right after I installed bootstrap from my VS code terminal. I ended up using the react-bootstrap-github stylesheet code instead and put it in my index.html!

score:1

I solved changed my "package.json" using this react-scripts": "2.1.8

score:1

I had the same issue. I run the following command and it is working fine now, without using Yarn.

"npm audit fix"

score:2

For me, downgrading node to v11.15.0 solved the error.

score:2

remove node_module and package-lock.json and use yarn instead of npm. This saved me hours.

score:2

I deleted the node modules package and reinstalled the node and then executed the node js commands. it worked fine for me.

score:3

I also had the same issue though am using MacOS the issue is kind of bug. I solved this issue by repeatedly running the commands,

  • sudo npm cache clean --force
  • sudo npm uninstall
  • sudo npm install

One time it did not worked but when I repeatedly cleaned the cache and after uninstalling npm, reinstalled npm, the error went off. Am using Angular 8 and this issue is common

score:3

Do these simple steps. Run the following

rm -rf node_modules/ package-lock.json  

and then

npm i

This worked for me.

score:4

đź‘Ť Solved it using Yarn's selective dependency resolutions

"resolutions": {
  "chokidar": "^3.3.1"
},

as some packages in my dependencies are still on older chokidar versions < 3

score:6

The @not-a-file gave will work only you can install the fsevents successfully。 but when I do that, I receive an error with this:

Error: EACCES: permission denied, mkdir '/Users/**/node_modules/jest-haste-map/node_modules/fsents/.node-gyp'

So ,I suggest you avoid this by use something like this:

sudo npm i fsevents --unsafe-perm=true --allow-root

And I also find this error may due to node version, when I use node 12,I can not install fsevents successfully , so I use nvm to modify my node version to v11.15.0

score:7

I solved with

sudo npm i fsevents --unsafe-perm

score:13

This is a well-documented issue on the react GitHub repo with a couple of options to try.

I solved my error by re-installing the fsevents npm i fsevents, which worked

score:21

below steps solved issue :

  • step 1 : removing node_module and yarn.lock
  • step 2 : yarn install
  • step 3 : yarn start

enter image description here

score:45

npm audit fix --force

It worked in my case


Related Query

More Query from same tag