score:2

Accepted answer

Strapi apparently only supports Node v14 (current LTS). Switch to that version (NVM?) and try again.

score:0

I change my nodeJS engine version to v14 like this and it worked :

  "engines": {
    "node": "14.x",
    "npm": "6.x"
  },

Source : the recommanded version is 12 at least, but 14 recommanded https://strapi.io/documentation/developer-docs/latest/setup-deployment-guides/installation/cli.html#step-1-make-sure-requirements-are-met

score:1

I had the same problem when deploying to heroku. It worked by changing the npm version from >=6.0.0 to 6.14.9 in package.json:

  "engines": {
    "node": ">=10.16.0 <=14.x.x",
    "npm": "6.14.9"
  }

Related Query

More Query from same tag