Accepted answer

well , have a glance of this to update the eclipse to 3.6

or change the manifest file code as.



use an unoffical build, i recommend to head over to xda developers.

here's a link to your phone:

xda developers have alot of information how to flash your device to a newer android version.


api level 11 is honeycomb (3.0) or later. as that is for tablets, you will need an ics (android 4.0) capable phone to test your code on a live device. as ics is not available for the desire officially, your best bet is to either buy a new phone or try to install cyanogenmod 9, which is an aftermarket firmware based on ics.

alternatively there is a library called support library from google that allows some post-11 api functions (like fragments) to be used on older phones. for that you need to decrease the minimumversion, and install the support library. check it's docuimetnation whether it is good for you.

or if you don't want to test it on a live device, then simply use the emulator, as it can emulate all kind of phones, up to android 4.2 (as of writing this post)


  1. use the emulator to run a virtual android device running 11+ - this is the preferred solution providing you can do everything you want against the avd and don't need things like multi-touch or bluetooth

  2. change back to min version 8 and find another way to accomplish what you want. this isn't a great solution but sometimes you just have to live with the older code base.

  3. root your desire and install a custom rom of the desired level. i've done this on my desire and it's not hard but runs the risk of ruining your device. not really the best reason to root and mod your phone.


since support library was also mentioned, i would like to add documentation to how to be backwards compatible

basically you just need to have target sdk version at the level you want to use apis from and minimum sdk version at whatever you want to support, however you'll need to provide alternate implementation(s) for older platforms or use the support library if it provides the apis you want (most of the time it does)


its very simple dear. your application supports api 11(honey comb) and your phone's version is 8(froyo). so you have to upgrade your phone to api 11(honey comb).


make your application version to api 8(froyo). but some new classes supported by api 11 is not available in it.

i give you one test thing just try this but not sure for the it will work or not(its a trick).

goto "project property" file and replace target api 8 to just api 11.


Related Query

More Query from same tag