Accepted answer

The best solution to this is to download a new ADT from


@Kalpesh DON'T delete SDK 23.0 it will remove your "tools" folder and you won't be able to run SDK Manager after that. I know because I have just done that. Bad suggestion!

The solution from Kikiwa worked for me.


I have also come across this issue and figure out few steps that will help in a way or other.

One thing to note that the error "This Android SDK requires Android Developer Toolkit version 23.0.0 or above" will only come if you have updated your Android SDK Tool and Android SDK Platform Tool before updating your ADT.

Here are the steps that will help you to get rid of this: -

  1. You can try the steps provided by Kikiwa but that might create some issues like removing your android SDK. So the solution is to re-configure your eclipse with re-installing the Android SDK.

  2. Steps given by user285oo6 will also create some issues like when you delete the Updated SDK 23.0 then it will also remove the files from Platform-tools and tools folder from SDK directory. Now your eclipse wont start as it wont find the necessary files that are required to identify Android SDK or it may throw and error says "cannot find tools for the SDK" or "cannot find the version of ADT" or "emulator.exe not found".

In this case the solution is to restore your SDK Manager files along with Platform-tools and tools folder. Now the question arises how you will get it? Below are links for the same

This will download the SDK platform ZIP files and it contains the SDK manager along with tools folder. My Suggestion is to extract them and replace the -tools folder -SDK Manager.exe -AVD Manager.exe in your android SDK directory.

Now you have latest ADT installed (if you have follow the user285oo6 steps. If not then install it using your eclipse with URL i.e. version 23.x.x and SDK on the older version.

Now you have to restart your eclipse and update the Android SDK tool and SDK Platform tool. This will work. I have done it for windows OS and was able to get it up and running

I know I am bit late but its always good to be late then never.

Please let me know if anyone has any question or confusion with the steps


On Linux (Ubuntu), I managed to solve the problem in a bit of a 'hackish' way. It may be useful if you're reluctant to download stuff all over again (like me) :)

Warning: I suspect this won't work if the ADT and SDK versions are too far apart. (For me, it worked for ADT 22.6.2 and Android SDK update 24.)

  1. Modify the file $SDK_HOME/tools/lib/plugin.prop ($SDK_HOME = base directory of your Android SDK installation), to contain the current ADT version, instead of the actual (updated) SDK version. In my case the original content of the file was


    which I changed as


This suppresses the "Please update ADT..." issue, but ADT won't work properly as it won't be able to identify some of the components relocated by newer SDK updates.

  1. Create shortcuts (symlinks) or copies of missing SDK components, at the locations where ADT expects to see them. You can find the expected locations using ADT's error consoles.

    For example, in my case, the DDMS console showed an error

    [2016-02-27 19:33:33 - DDMS] DDMS files not found: /usr/lib/sdk/tools/hprof-conv

    as soon as I tried to switch to the DDMS perspective. So I just created a symlink $SDK_HOME/tools/hprof-conv pointing to $SDK_HOME/platform-tools/hprof-conv (which has been relocated):

    me@computer:$SDK_HOME/tools$ ln -s ../platform-tools/hprof-conv hprof-conv

For me, after these 2 steps, ADT started working without any problems/errors.


You are not alone.

This thing happened also to me. I tried many many solutions suggested on the internet but I had to use the "PLAN B"

I downloaded and installed new adt bundle and reimported all my projects and libraries. It takes some time but it is not that long :)

I hope that google will come up with fix, because the update to also didnt work for me (same error).

So keep smiling and install new ADT :)


no need to do any thing,

just download new eclipse, install ADT 23.0.0 from below link

your problem solve...

its happened because you have SDK 23.0.1 and ADT 23.0.1 update not available....

yesterday i have same issue, i have solved that..


I also got the error of OP this morning. I clicked on "Check for Updates" but it was always saying "No updates available".

I found this thread and thought "Oh man, I'm gonna sit on this all day".

But lucky for me (and for you who will find this thread perhaps in a few weeks), the solution is getting easier. I just did this:

  1. Help > Install New Software
  2. choose the update site
  3. it offered me the new ADT-Packages with version 23.0.3 and I chose all of them
  4. it showed me the known conflicting-dependency-error BUT offered me directly a solution: It will deinstall the 22* ADT-packages for me. I just clicked "ok" and it automatically deinstalled the old packages and installed the new ones :)


AS you have done the upgrade to SDK 23.0 without upgrading the ADT it will show this kind error as you have mentioned in the screen shot.

Simply upgrading the SDK to 23.0 is of no use until and unless you also update the related development tool in ADT.

Follow the steps

  1. First delete the SDK 23.0 and update the ADT to 23.0
  2. For doing the update you need to click on Install new software from help and choose the ADT/ under the link upon which you get the new Development tools to update click all >next to continue .
  3. Upon successful completion you can now update the SDK to 23.0.

Note:- Many of those who tried to update the SDK have face a problem Cannot complete the installation because of conflict dependancy Cannot complete the installation because of conflict dependancy

So its better to just stick to the 22.6v of the ADT. The update to 23.0 is filled with bugs and it will take some time to fix the bugs


  1. Go to Help - About Eclipse and click Installation Details
  2. On tab Installed Software, select all row that has version 22.6.3 then click Uninstall
  3. Go to Help - Install new software, select work with ADT Plugin -
  4. Check the Developer Tools and now install without conflict


If you have a conflict with the previous version:

  1. Select Help > Install New Software
  2. Click on already installed
  3. Select all Android software on version 22.*
  4. Click on Uninstall
  5. Work with:
  6. Select Developer Tools and Next
  7. Next, Accept the license agreement and Finish.

EDIT : This trick is probably no more necessary!

Try to upgrade your SDK tools to 23.0.2+ and build&platform tools to rev 20 before.

Related Query

More Query from same tag