score:170

Accepted answer
  1. go to your project in the navigator, right click on properties.

  2. go to the java build path tab on the left.

  3. go to the libraries tab on top.

  4. click add external jars.

  5. go to your adt bundle folder, go to sdk/extras/android/support/v7/appcompat/libs.

  6. select the file android-support-v7-appcompat.jar

  7. go to order and export and check the box next to your new jar.

  8. click ok.

score:0

i had the same issue every time i tried to create a new project, but based on the console output, it was because of two versions of android-support-v4 that were different:

[2014-10-29 16:31:57 - headphonesplitter] found 2 versions of android-support-v4.jar in the dependency list,
[2014-10-29 16:31:57 - headphonesplitter] but not all the versions are identical (check is based on sha-1 only at this time).
[2014-10-29 16:31:57 - headphonesplitter] all versions of the libraries must be the same at this time.
[2014-10-29 16:31:57 - headphonesplitter] versions found are:
[2014-10-29 16:31:57 - headphonesplitter] path: c:\users\jbaurer\workspace\appcompat_v7\libs\android-support-v4.jar
[2014-10-29 16:31:57 - headphonesplitter]   length: 627582
[2014-10-29 16:31:57 - headphonesplitter]   sha-1: cb6883d96005bc85b3e868f204507ea5b4fa9bbf
[2014-10-29 16:31:57 - headphonesplitter] path: c:\users\jbaurer\workspace\headphonesplitter\libs\android-support-v4.jar
[2014-10-29 16:31:57 - headphonesplitter]   length: 758727
[2014-10-29 16:31:57 - headphonesplitter]   sha-1: efec67655f6db90757faa37201efcee2a9ec3507
[2014-10-29 16:31:57 - headphonesplitter] jar mismatch! fix your dependencies

i don't know a lot about eclipse. but i simply deleted the copy of the jar file from my project's libs folder so that it would use the appcompat_v7 jar file instead. this fixed my issue.

score:0

i fixed it adding these lines in the build.grandle (app module)

dependencies {
   compile filetree(dir: 'libs', include: ['*.jar']) //it was there
   compile "com.android.support:support-v4:21.0.+" //added
   compile "com.android.support:appcompat-v7:21.0.+" //added
}

score:0

recent sdk-manager's download does not contain android-support-v7-appcompat.jar but the following dir contains aar file c:\users\madan\android-sdks\extras\android\m2repository\com\ android\support\appcompat-v7\24.2.1\appcompat-v7-24.2.1.aar this file can be imported by right-click project, import, select general, select archieve and finally select aar file. even this does not solve the problem. later remove 'import android.r' and add 'import android.support.v7.appcompat.*;' follow this tutorial for other details: http://www.srccodes.com/p/article/22/android-hello-world-example-using-eclipse-ide-and-android-development-tools-adt-plugin

score:0

completing the answer @jorgesys, in my case it was exactly the same way but the export configuration was missing in the library:

  1. right click on appcompat-v7 project;
  2. properties;
  3. left tab, java build path;
  4. right tab, order and export;
  5. check classes.jar with appcompat-v7;

export lib

score:4

in my case, the auto-generated project appcompat_v7 was closed. so just open up that project in package explorer.

hope this help.

score:26

i tried the answer described here but it doesn´t worked for me. i have the last android sdk tools ver. 23.0.2 and android sdk platform-tools ver. 20

the support library android-support-v4.jar is causing this conflict, just delete the library under /libs folder of your project, don´t be scared, the library is already contained in the library appcompat_v7, clean and build your project, and your project will work like a charm!

enter image description here


Related Query

More Query from same tag