score:77

Accepted answer

the most common reason for this message seems to be unzipping the eclipse zip file wrongly (for instance unzipping without recreating the directory structure). therefore please unzip the zipped eclipse again with a good unzip tool (like 7-zip) and make sure that the necessary sub directories are created during the extraction.

also make sure that the path to the unzipped eclipse does not get very long. i've seen cases where eclipse was unzipped into a deeply nested directory structure (to put it at some place into an svn repository) and that led to the same error message.

if that still doesn't work, you may try launching eclipse.exe with administrative rights. that should not really be necessary, but maybe your access rights are somehow broken after the re-installation of windows.

score:1

i got this error because on windows the zend studio icon in the start menu was still pointing at the previous version of zend studio. once i changed the target to the new path, the error went away.

score:1

my issue was much simpler. i had created a shortcut to launch the eclipse executable by dragging it from the folder to the screen. clicking on the created shortcut icon gave the above error.

issue: the executable was getting launched from the desktop location instead of the eclipse directory where it had been unzipped.

solution: create a new shortcut by right-clicking in the desktop area and providing the target executable from the browse window. this creates the shortcut properly and launches the executable from the right home directory.

score:1

i had same problem and it seems that there is wrong "--launcher.library " address in eclipse.ini file. so i have just changed it and

score:1

in my case i had to redownload it, something was wrong with the one i downloaded. its size was far much less than the one on the website.

score:1

just add -vm c:\java\jdk\1.6\bin\javaw.exe before -vmarg in eclipse.ini this works for me.hope this will help you good luck...

score:1

windows 8 follow these 3 steps:

  1. locate eclipse file.
  2. create shortcut on desktop.
  3. double click on the eclipse shortcut to open the application.

score:1

i was facing the same issue with eclipse juno & windows xp. after changing a lot of things in eclipse.ini still it was not working and then i deleted it, i don't know why its starts working after deleting this init file. you may try for yours

score:1

on windows eclipse installer app writes also below admin user directory. and when i started the same eclipse as normal (another) user, it could not find admin users ecplise directory. that directory is in eclipse.ini file. (this installer has made for neon eclipse.)

score:1

run eclipse.exe file as an administrator. it worked for me

score:2

open eclipse.ini and replace with this ~

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
-product
com.android.ide.eclipse.adt.package.product
--launcher.xxmaxpermsize
256m
-showsplash
com.android.ide.eclipse.adt.package.product
--launcher.xxmaxpermsize
256m
--launcher.defaultaction
openfile
-vmargs
-dosgi.requiredjavaversion=1.6
-xms40m
-xmx768m
-declipse.buildid=v21.0.0-531062

this work for me, good luck ~

score:3

i've the same problem, and the below solution exactly work for me....!

edit eclipse.ini file and remove these two lines:

--launcher.library .%%..\eclipse\plugins\eclipse\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813

make sure make a separate copy of this file before any changing...:)

score:3

you might want to check that library

**org.eclipse.equinox.launcher_(version).dist.jar**
and 
**plugins/org.eclipse.equinox.launcher.gtk.linux.x86_(version).dist**
exists on your system. 

make sure that the version of libraries mentioned in eclipse.ini and the version that exists on your system is same. usually after upgrade this mismatch occurs and eclipse fails to locate the required jar. please take a look at this blog post here

score:3

i just had this problem and it seems to be related to permissions somehow. i initially unzipped it to my program files folder, in windows 8. after unzipping it directly to c: the program started normally.

score:3

please check "eclipse.ini" file:

normally there should not be any hard code path like:
(for example)
p:\eclipse\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20140603

if you see anything like this please follow these steps:
1. make backup of the file
2. then open the file original file in editor
3. change the static path to :-- plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20140603 (and save file and open your eclipse it will work amazing)

score:4

you have to copy in users/user/.p2 and .eclipse from old location when it come from and older location. for example i made a copy from computer to another, and i had this error, then i copied those folders and it worked !

score:5

solution for mac

reason: eclipse is copied from one location to another.

solution: need to update path(s) in eclipse.ini. my eclipse.ini was found in /applications/eclipse/eclipse.app/contents/macos/eclipse.ini.

we need to update the path for plugins\org.eclipse.equinox.launcher_1.0.100.v20080509-1800.jar.

score:8

same issue on my mac with a pre-packaged rcp client that was unzip only. the other answers pointed me to the eclipse.ini where all the paths looked valid, tried to check the working directory of my eclipse bundle that doesn't see that easy to do. seems when finder starts an application it's working directory is / so that seems to be the issue.

updated both references in my eclipse.ini to absolute paths and voila!

-startup
/applications/rcpclient/client/eclipse/plugins/org.eclipse.equinox.launcher_1.1.1.r36x_v20101122_1400.jar
--launcher.library
/applications/rcpclient/eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.2.r36x_v20101019_1345
...

score:22

edit the eclipse.ini file and remove these two lines:

-startup
plugins\org.eclipse.equinox.launcher_1.0.100.v20080509-1800.jar 

Related Query

More Query from same tag