score:-1

i had the same issue.

just removed all my worskspace:

c:\users\<name>\.<eclipse similar name>

score:1

i have the same error after attempting to update android development toolkit (adt) plugin for eclipse 3.5.

i haven't figured out what caused this but i re-installed (unziped eclipse) to fix it.

score:1

my case seems to be invalid jre version.

1.7+ required while i launched with 1.6

plus: i filtered some plugin jars which might be required. so changed to select all

score:1

you might be launching your application from a product file which is not linked to the plugin file. reset your workspace and launch using the manifest.mf > overview > testing > launch.

score:3

just copying the content of the zip-file to its prefered location from the zip-file will give you this error when you attempt to run the only executable that is visible in the archive. it is named similarly but it is not the real thing.

you should let the archive extract itself to make the installation complete correctly. doing so gives you an executable named eclipse.exe with which you will not get this error.

score:3

check jar files in your project which are mentioned in config.ini if not proper then install manually and then follow the following steps:

  1. select your product configuration file, right-click on it and select run as run configurations
  2. select "validate plug-ins prior to launching". this will check if you have all required plug-ins in your run configuration. if this check reports that some plug-ins are missing, try clicking the "add required-plug-ins" button. also make sure to define all dependencies in your product. and your application start running

score:3

this can a time consuming problem. for those who want to get on with their work because they do not want to waste much time, i would like to suggest that you download the zip file and unpack the zip file and use it. the zip file is available for all major os.

https://www.eclipse.org/downloads/packages/

here instead of hitting the download button, which will download the eclipse installer, scroll to the middle area where a list of the various eclipse ides with their respective features are shown. select the eclipse ide of your like and click on the link on the right-hand-side to download the zip or corresponding file for your os version.

if you still want to use your other eclipse installations because, for example, you have plugins installed, then download the eclipse installer and on the right-hand top corner press the icon with 3 minus. after that press update, then after restart, install the version of eclipse ide, which you want (the one that you want to reactivate) in a different folder. the installation will take some time. after the installation is finished you should be able to start your old eclipse ide.

score:6

i just went through this. if you want to manually move your eclipse installation you need to find and edit relative references in the following files.

relative to eclipse install dir:

  • configuration/org.eclipse.equinox.source/source.info
  • configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
  • configuration/config.ini
  • eclipse.ini

for me in all these files there was a ../ reference to a .p2 folder in my home directory. found them all using a simple grep:

grep '../../../../' * -r

then just hit it with sed or manually go change it. in my case i moved it up one folder so easy fix:

grep -rl '../../../../' * -r | xargs sed -i 's/..\/..\/..\/..\//..\/..\/..\//g'

now eclipse runs fine again.

score:37

in your config.ini file of eclipse eclipse\configuration\config.ini check this three things:

osgi.framework=file\:plugins\\org.eclipse.osgi_3.4.2.r34x_v20080826-1230.jar
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.0.v20080604.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configurl=file\:org.eclipse.equinox.simpleconfigurator\\bundles.info

and check whether these jars are in place or not, the jar files depend upon your version of eclipse .


Related Query

More Query from same tag