score:122

Accepted answer

in eclipse, click on run in the toolbar then run configurations. select your application and click on the target tag. you can then select which avd to use or set it to manual so it asks you each time you run the app.

note that if the avd's android version is lower than the minimum api level set in the manifest, the avd will not appear in the list.

score:0

in new eclipse kepler version, right click your project, then click run as->run configurations->"target" tab, you will see all avds in the list, select one as a preferred one, then "apply" and "run"

score:4

in androidmanifest.xml, see that your minsdkversion and targetsdkversion match your device.


Related Query

More Query from same tag