score:49

Accepted answer

update: 7/11/2017 i've not had this problem reoccur in a couple of years now. either eclipse fixed the problems or a more recent version of mac osx has fixed something. for the record i'm running eclipse 4.5.2 on osx 10.11.6.

update: 4/29/2011 now it looks like this is not a workspace or keyboard preferences issue at all. this just happened again but restoring from older workspaces did not fix the issue. i finally had to reboot my mac which seemed to resolve things. i'm going to try a restart in the future immediately if i see this again. i've submitted this bug with eclipse. please add a "me too" comment to the bug if it has not been fixed and you can reproduce this on your system.

i also have heard that on macs, you can solve this by getting the unit to sleep either by closing the laptop lid or pulling the apple menu down to sleep, wait a few seconds, and then starting it again. i've not tried this yet.

btw, when this happens refreshing and other mechanisms have not worked.


update: 4/13/2011 although the below instructions did fix my keyboard issues, i discovered other problems with my configuration and was finally forced to recover my workspace from backups.


note: this is not recommended but is here for information purposes. typically these keys are handled by the native widget and are not defined.

so i just had the same problem under eclipse 3.6.2.r362 on mac osx 10.6.7. delete to the left and arrows not working. they worked in other applications. option-arrows worked fine to move a selection around. arrows worked in the keyboard preferences window. switching to another application and back didn't work. restarting eclipse made no difference. switching keyboard schemes from emacs -> default -> emacs didn't work. pressing all of the modifier keys did nothing. i tried all of the following and nothing works: rebuilding the project, refreshing the source, restarting eclipse.

finally, i was able to fix this by going to the preferences -> general -> keys and resetting each of the bindings for the following keys. the bindings for each of the keys were blank.

  • delete previous to backspace
  • line up to up arrow
  • line down to down arrow
  • previous column to left arrow
  • next column to right arrow

this worked but then i noticed that all of the emacs key bindings were screwed. i thought they worked before so i'm not sure when this happened. i had to restore default key bindings (after writing down the ones that i had customized) and then restore my customized settings.

makes me wonder what other key bindings have been reset and what did it. frustrating but at least i can get back to coding.

eclipse keyboard preferences window

score:0

macbook pro 10.6.8, eclipse helios all of a sudden delete and arrows no longer work. reboot worked for me.

score:0

just in case this helps someone... i accidentally got things working again by doing the following:

  1. opened the offending file from the command line (i used 'vi').
  2. made the edit i wanted to make and saved the file.
  3. went back into eclipse to refresh and redeploy my app.

as soon as the editor (this was a jsp file, btw) refreshed, i once again had full use of arrow, delete, etc.

ymmv

  • jack

score:0

i got this same problem when i started using jrobot. in one piece of code i pressed the mouse but did not release. by releasing the mouse in a later piece of code i managed to solve the issue. you can recreate this problem using the code below. release the mouse button to solve the issue.

robot robot;

try {
 robot = new robot();       
 robot.mousepress(inputevent.button2_mask);
 //robot.mouserelease(inputevent.button2_mask);
} catch (awtexception e1) {
// todo auto-generated catch block
 e1.printstacktrace();
}

score:0

i am also facing the same problem. in my case only the delete key is not working. i am using eclipse helios in ubuntu. the solutions given here are not working. however, restarting solves the issue.

score:0

i have the suspicion that this happens after updating java on my mac. so after updating java it seems to be a good idea to reboot the machine always.

score:0

pressing left and right mouse buttons simultaneosly multiple times worked for me.

score:0

using eclipse luna (4.4) on redhat and viewing via xming (windows 7, 64-bit), i could not use backspace, arrows, delete or even enter, but alphanumeric worked. this problem was not intermittent, but always there from the start. for me, i found that setting a break-point in the code, running and allowing eclipse to switch perspectives fixed it every time. hope it helps someone else as the above suggestions (ie switching editors, changing key mappings, refreshing and restarting eclipse) did not work for me.

one interesting diagnostic of the problem i had was that going to the screen where you change the key-mappings, i was able to use the delete key. but not in java files or untitled text files.

score:0

worked!!!

i'm using eclipse luna and windows 7, but guess it works in all kinds as well.

in eclipse, go to tab window->preferences->general->keys

then, find the command "delete" and "delete previous" in the list, and check if they are assign with something or not. if it is assign with the wrong key, click in "unbind command".

just select the command that you want to change and press the key that you want to be on the "binding" field.

i think it works for next, next column, previous, previous column, line up, line down, or whatelse you want!!

score:0

had, similar problem with not working “enter” and “delete”, none of above methods helped me – to fix problem i had to switch to default java formatter (one i was using somehow stopped working)

score:0

for me it was that the keyboard layout accidentally changed to vietnamese language and there are inherent key mapping combinations that create trouble when editing.

score:1

in windows and linux environments i have experienced such issues when the system believes a modifier key is pressed. by pressing and releasing all modifier keys the issues often perish. however, on osx i did not experience such issues, so this might be entirely wrong.

if the simple idea does not solve the issue, you could try to start a new workspace to see whether some preference causes the issue; or you could download a new helios instance to check whether its working. i know, these are all serious issues, but may locate the problem.

otherwise, you shall take a look at the question asked not long ago about keyboard issues, maybe there is some hint how to solve it.

score:1

i had the same problem with the "delete" key in eclipse 3.7.0 on windows vista. suddenly the key stopped working and i couldn't figure out why. recently i found a way to fix it when the problem occurs - it works for me every time:

in a code editor window in eclipse, hoover on some method or variable or what have you, until the popup window appears with "press 'f2' for focus" in the lower right corner. click the popup window to switch focus, then click the editor window again so the pop-up disappears, and voilà, the delete key works again.

score:1

had this same issue. turned out to be my middle button on my wireless mouse being pushed in my laptop bag. normally i turn my mouse off, but this time i forgot. glad that other people had this problem, otherwise i'd still be looking for the cause.

score:1

i have encountered this problem for years. it happens so infrequently however, that i almost always forget what i did to solve it. restarting fixes it most of the time i think, and a few times "refreshing" worked, but nothing works 100% of the time.

in any case, someone on the bug report suggested just putting macbook in sleep cycle. this worked like a charm for me, so putting it out there for future reference.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=344290#c24

incidentally, i have experienced similar behavior with other applications, in particular firefox. my thought is that it has to do with key bindings in general, and any application that provides overrides for defaults in the os (this is a pretty huge assumption, so take with a correspondingly large grain of salt). i have also had this happen to me in xcode, but a simple restart of the application fixes, whereas with eclipse that wasn't sufficient most of the time.

score:1

using eclipse juno on win xp i also experience this issue. restarting the workbench using file > restart does not work, but closing eclipse and starting again with -clean at the command prompt the keys start functioning again, without restart windows.

score:1

note - just found this fix elsewhere - you can fix this on mac osx by force-killing finder. that worked for me perfectly. didn't need to restart!

score:1

for some odd reason, opening the preferences window and closing it right away, solves this problem for me (other solutions here didn't work).

score:2

also check that someone has not installed the vrapper plugin so that eclipse accepts vi/vim like commands. if this is the case pressing i allows you access the editor window. if you are unaware that a work college has installed it (glares at someone) it can be a right $%#&$@! if installed there will be a v icon in the top toolbar. this plugin can be removed by going to the directory where eclipse is installed in a term window and running

find . -name '\*vrapper\*' -exec rm -rf {} \;

it is that or tax you brain but supposedly increase your productively by learning all the vim commands. hope this helps someone...

score:5

for me, the root cause was my mouse.

backspace and navigation keys did not work. i could fix this temporarily by manually setting the key bindings as described on this page.

the root cause and permanent solution was fixing the stuck 3rd mouse button on my evoluent vertical grip mouse. since i never used that button, i didn't notice that it was permanently engaged, probably from the mouse sliding off the desk on to the ground one too many times. once i was able to get the button unstuck, the problem was solved immediately.

this was really frustrating. i spent weeks wondering why it was happening and sporadically searching the web for answers. of course i had a temporary solution, but the fact that it kept happening was annoying. i tried reinstalling eclipse from scratch, trying different versions and switching workspaces, but nothing worked. i'm surprised it ended up being a stuck mouse button after all that.

score:9

same weird problem, this worked for me: i just figured out that if i switch editor and then back again, backspace starts working again. (source)

score:12

if you see the same symptoms on eclipse windows, just press all your mouse buttons (including the wheel if you have one) at the same time together, and that seems to fix it.

score:82

i was able to "restore" arrow and backspace keys by "refreshing" the project.

eclipse project refresh


Related Query

More Query from same tag