Node.js downgrade you node package into a stable version like 10.13.0 and then re-install the node modules.it will work

problem was with the versions not matching up. I also had 2 NodeJS installation paths and that was throwing things off.

I uninstalled them all, started from the beginning and used brew to reinstall.

Then checked that the versions were all compatible.

I also had to install node-sass and referred to this compatibility table to get the correct version - https://github.com/sass/node-sass#node-version-support-policy

Now its working and I can get on developing :) As of today Im running Node v17.0.1 Npm v8.1.0 Gulp cli v2.3.0

  • Remove package-lock.json or yarn.lock file.

  • Then remove node_modules.

  • After that modify the package.json file-

    "dependencies": { "gulp": "^4.0.0" }

  • Then run- npm install

my workflow if this error appears:

  1. npm install

  2. npm install gulp

  3. create file npm-shrinkwrap.json with

    {
      "dependencies": {
        "graceful-fs": {
            "version": "4.2.2"
         }
      }
    }
    
  4. npm install (again) (Not npm install gulp again! Very important - otherwise the error will be come back)

Install gulp and add your Node.js version to the package.json file like so:

{
  "dependencies": {
    "node":  "^10.16.3"
  }
}