Accepted answer
  1. In the same directory where you have package.json create a npm-shrinkwrap.json file with the following contents:

        {
          "dependencies": {
            "graceful-fs": {
                "version": "4.2.2"
             }
          }
        }
    
  2. Run npm install, and don't worry, it will update npm-shrinkwrap.json with a bunch of content.

  3. Run gulp to start the project.

  1. package.json create an npm-shrinkwrap.json file with the following contents:

    npm-shrinkwrap.json
    {
      "dependencies": {
        "graceful-fs": {
          "version": "4.2.2"
        }
      }
    }
    

  2. Run npm install, and don't worry, it'll update npm-shrinkwrap.json with a bunch of content.

Now, fire your gulp command and enjoy, it should be working just fine!

known issue for that package as it depends on graceful-fs behind the scenes.

Fix: 1. upgrade graceful-fs to 4.x or higher

Fix: 2. use webshot-node instead

I have fixed the problem with the following steps:

  1. Installing NVM
  2. Installed lts/dubnium using command nvm install lts/dubnium
  3. Use lts/dubnium using command nvm install lts/dubnium

 two options here

  1. Either upgrade to gulp 4 or else
  2. downgrade to an earlier Node.js version.

keeping Node.js v12 while using the latest gulp ^4.0, follow these steps:

Update the command-line interface (just for precaution) using:

npm i gulp-cli -g

Add/Update the gulp under dependencies section of your package.json file

"dependencies": {
  "gulp": "^4.0.0"
}

Delete your package-lock.json file.

Delete your node_modules folder.

Finally, run npm i to upgrade and recreate a brand new node_modules folder and package-lock.json file with correct parameters for Gulp ^4.0:

npm i

Note Gulp.js 4.0 introduces the series() and parallel() methods to combine tasks instead of the array methods used in Gulp 3, and so you may or may not encounter an error in your old gulpfile.js script.

eem to be using Node.js 17.8.0, which is currently the latest version. Now, Gulp 3 does not work in any currently maintained version of Node.js

faced the exact same issue recently. Actually gulp 3.9 doesn't work with the latest version of node. Either upgrade gulp to v4 or downgrade node version. node v10 worked for me.