package.json

Changed "@angular-devkit/build-angular": "^0.800.0" --> "@angular-devkit/build-angular": "^0.10.0" Then:

 npm install
 ng serve

Specs:

Angular CLI: 6.1.5 Node: 10.15.3 OS: win32 x64 Angular: 6.1.9

Update @angular-devkit/build-angular to "^0.13.9" . Then run npm install and after that, run npm serve.

Specs:

Angular: 7.2.15
Angular CLI: 7.3.9
Node: 11.2.0
OS: darwin x64

worked for me.

> 1. npm uninstall @angular-devkit/build-angular 

> 2. npm install @angular-devkit/build-angular@0.13.0

commands worked for me:

npm uninstall @angular-devkit/build-angular

npm install @angular-devkit/build-angular@0.13.0

Updated package.json from "@angular-devkit/build-angular": "^0.800.1" to "~0.13.9"

run npm install

worked for me as well,

  1. npm uninstall @angular-devkit/build-angular
  2. npm install @angular-devkit/build-angular@0.12.4

Angular Cli 8 support Node Js 10.9+. I have Node.js 8, after update to 10.16 works fine.

have been caused by the @angular-devkit/build-angular node package as I have managed to resolve this issue by rolling back my back down from ^0.800.0 to ^0.12.4.